#!/usr/nekoware/bin/bash # https://wiki.preterhuman.net/IRIX_Installation_and_Customization echo 'Enter hostname' read HOSTNAME echo "$HOSTNAME" > /etc/sys_id chkconfig autoconfig_ipaddress on chkconfig ipaliases off # Set aliases in /etc/config/ipaliases.options #ef0 192.168.178.15 netmask 0xffffff00 broadcast 192.168.178.255 #ef0 192.168.178.17 netmask 0xffffff00 broadcast 192.168.178.255 #ef0 192.168.178.16 netmask 0xffffff00 broadcast 192.168.178.255 /etc/init.d/network stop /etc/init.d/network start echo 'domain home.local nameserver 192.168.178.1' > /etc/resolv.conf chmod 644 /etc/resolv.conf perl -pi -e 's/hosts:.*/hosts: files dns/' /etc/nsswitch.conf